Package tcpip

Failed to find a solution:

no platform:
2024-01-29 14:56.47 [INFO] Solving for ocaml-base-compiler, ocaml,
                           tcpip using opam_repository_commit 251c5edf2ecdd2541c324dacb931c3606ee71eeb

2024-01-29 14:56.53 [INFO] base: eliminated all possibilities in 2.78 s

2024-01-29 14:56.53 [INFO] = base =

2024-01-29 14:56.53 [INFO] Can't find all required versions.
Selected: base-bigarray.base base-bytes.base base-domains.base base-nnp.base
          base-threads.base base-unix.base camlp4.4.02.0-1modular-implicits
          cmdliner.1.2.0 conf-time.1 conf-which.1 cppo.1.6.9 dune.3.13.0
          macaddr.5.5.0 ocaml-config.3 ocaml-options-vanilla.1
          ocamlbuild.0.14.3 ocamlfind.1.9.6 ocplib-endian.1.2 ounit.2.2.7
          ounit2.2.2.7 seq.base stdlib-shims.0.3.0 tuntap.2.0.0
          type_conv.113.00.02 tcpip&ocaml&ocaml-base-compiler
          ocaml-base-compiler ocaml-base-compiler ocaml base-domains ocaml
          ocaml-base-compiler
- cstruct -> cstruct.1.7.1
    cstruct-lwt 0 requires < 3.0.0
    mirage-profile 0.6.1 requires <= 1.9.0
- cstruct-lwt -> cstruct-lwt.0
    mirage-console 2.1.3 requires < 3.4.0
    mirage-net-unix 2.2.3 requires = 0
- io-page -> (problem)
    Rejected candidates:
      io-page.3.0.0: Requires cstruct >= 2.0.0
      io-page.2.4.0: Requires cstruct >= 2.0.0
      io-page.2.3.0: Requires cstruct >= 2.0.0
      io-page.2.2.0: Requires cstruct >= 2.0.0
      io-page.2.1.0: Requires cstruct >= 2.0.0
      ...
- ipaddr -> (problem)
    tcpip 2.4.2 requires >= 2.2.0 & < 3.0.0
    Rejected candidates:
      ipaddr.5.5.0: Incompatible with restriction: >= 2.2.0 & < 3.0.0
      ipaddr.5.4.0: Requires macaddr = 5.4.0
      ipaddr.5.3.1: Requires macaddr = 5.3.1
      ipaddr.5.3.0: Requires macaddr = 5.3.0
      ipaddr.5.2.0: Requires macaddr = 5.2.0
      ...
- lwt -> (problem)
    mirage-console 2.1.3 requires < 5.0.0
    Rejected candidates:
      lwt.5.7.0: Incompatible with restriction: < 5.0.0
      lwt.5.6.1: Requires ocaml >= 4.08 & < 5.1
      lwt.5.6.0: Requires ocaml >= 4.08 & < 5.1
      lwt.5.5.0: Requires ocaml (>= 4.02.0 | >= 4.06.0) & < 5.0
      lwt.5.4.2: Requires ocaml >= 4.02.0 & < 5.0
      ...
- mirage-clock-unix -> mirage-clock-unix.1.0.0
    tcpip 2.4.2 requires >= 1.0.0 & < 1.2.0
- mirage-console -> mirage-console.2.1.3
    tcpip 2.4.2 requires < 2.2.0
- mirage-net-unix -> mirage-net-unix.2.2.3
    tcpip 2.4.2 requires >= 1.1.0 & < 2.3.0
- mirage-profile -> mirage-profile.0.6.1
    tcpip 2.4.2 requires < 0.8.0
- mirage-types -> (problem)
    mirage-clock-unix 1.0.0 requires >= 0.3.0 & < 3.0.0
    mirage-net-unix 2.2.3 requires >= 2.3.0 & < 3.0.0
    Rejected candidates:
      mirage-types.3.10.8: Incompatible with restriction: >= 0.3.0 & < 3.0.0
      mirage-types.3.10.7: Incompatible with restriction: >= 0.3.0 & < 3.0.0
      mirage-types.3.10.6: Incompatible with restriction: >= 0.3.0 & < 3.0.0
      mirage-types.3.10.5: Incompatible with restriction: >= 0.3.0 & < 3.0.0
      mirage-types.3.10.4: Incompatible with restriction: >= 0.3.0 & < 3.0.0
      ...
- mirage-types-lwt -> mirage-types-lwt.2.5.0
    mirage-console 2.1.3 requires < 3.0.0
    tcpip 2.4.2 requires >= 2.2.0 & < 2.6.0
- mirage-unix -> (problem)
    mirage-console 2.1.3 requires >= 1.1.0
    tcpip 2.4.2 requires >= 1.1.0 & <= 2.6.0
    Rejected candidates:
      mirage-unix.5.0.1: Incompatible with restriction: >= 1.1.0 & <= 2.6.0
      mirage-unix.5.0.0: Incompatible with restriction: >= 1.1.0 & <= 2.6.0
      mirage-unix.4.0.1: Incompatible with restriction: >= 1.1.0 & <= 2.6.0
      mirage-unix.4.0.0: Incompatible with restriction: >= 1.1.0 & <= 2.6.0
      mirage-unix.3.2.0: Incompatible with restriction: >= 1.1.0 & <= 2.6.0
      ...
- ocaml -> ocaml.5.1.0
    User requested <= 5.1.0
- ocaml-base-compiler -> ocaml-base-compiler.5.1.0
    User requested >= 4.04.1
    ocaml-base-compiler|ocaml-variants|ocaml-system|dkml-base-compiler ocaml-base-compiler requires >= 5.1.0~ & < 5.1.1~
- ocaml-variants -> (problem)
    Rejected candidates:
      ocaml-variants.5.3.0+trunk: In same conflict class (ocaml-core-compiler) as ocaml-base-compiler
      ocaml-variants.5.2.0+trunk: In same conflict class (ocaml-core-compiler) as ocaml-base-compiler
      ocaml-variants.5.1.2+trunk: In same conflict class (ocaml-core-compiler) as ocaml-base-compiler
      ocaml-variants.5.1.1+tsan: In same conflict class (ocaml-core-compiler) as ocaml-base-compiler
      ocaml-variants.5.1.1+options: In same conflict class (ocaml-core-compiler) as ocaml-base-compiler
      ...
- sexplib -> (problem)
    cstruct 1.7.1 requires < 113.01.00
    Rejected candidates:
      sexplib.v0.16.0: Incompatible with restriction: < 113.01.00
      sexplib.v0.15.1: Incompatible with restriction: < 113.01.00
      sexplib.v0.15.0: Incompatible with restriction: < 113.01.00
      sexplib.v0.14.0: Incompatible with restriction: < 113.01.00
      sexplib.v0.13.0: Incompatible with restriction: < 113.01.00
      ...
- tcpip -> tcpip.2.4.2
    User requested = 2.4.2