Package shared-block-ring

Failed to find a solution:

no platform:
2024-01-29 14:46.38 [INFO] Solving for ocaml-base-compiler, ocaml,
                           shared-block-ring using opam_repository_commit 251c5edf2ecdd2541c324dacb931c3606ee71eeb

2024-01-29 14:46.45 [INFO] base: eliminated all possibilities in 2.99 s

2024-01-29 14:46.45 [INFO] = base =

2024-01-29 14:46.45 [INFO] Can't find all required versions.
Selected: base-bigarray.base base-bytes.base base-domains.base base-nnp.base
          base-threads.base base-unix.base camlp4.4.02.0-1modular-implicits
          cmdliner.1.2.0 conf-pkg-config.3 conf-which.1 cppo.1.6.9
          csexp.1.5.2 cstruct.6.2.0 dune.3.13.0 dune-configurator.3.13.0
          fmt.0.9.0 io-page.3.0.0 lwt.5.7.0 ocaml-config.3
          ocaml-options-vanilla.1 ocamlbuild.0.14.3 ocamlfind.1.9.6
          ocplib-endian.1.2 ounit.2.2.7 ounit2.2.2.7 seq.base
          stdlib-shims.0.3.0 topkg.1.0.7 type_conv.113.00.02
          shared-block-ring&ocaml&ocaml-base-compiler ocaml-base-compiler
          ocaml-base-compiler ocaml base-domains ocaml ocaml-base-compiler
- io-page-unix -> (problem)
    Rejected candidates:
      io-page-unix.2.3.0: Requires io-page = 2.3.0
      io-page-unix.2.2.0: Requires io-page < 3.0.0
      io-page-unix.2.1.0: Requires io-page >= 2.1.0 & < 3.0.0
      io-page-unix.2.0.1: Requires io-page >= 2.0.0 & < 3.0.0
      io-page-unix.2.0.0: Requires io-page >= 2.0.0 & < 3.0.0
      ...
- mirage-block-unix -> (problem)
    shared-block-ring 1.0.0 requires <= 2.4.0
    Rejected candidates:
      mirage-block-unix.2.14.2: Incompatible with restriction: <= 2.4.0
      mirage-block-unix.2.14.1: Incompatible with restriction: <= 2.4.0
      mirage-block-unix.2.14.0: Requires ocaml >= 4.06.0 & < 5.0
      mirage-block-unix.2.13.0: Requires ocaml >= 4.06.0 & < 5.0
      mirage-block-unix.2.12.1: Requires ocaml >= 4.06.0 & < 5.0
      ...
- mirage-types -> mirage-types.1.0.0
    shared-block-ring 1.0.0 requires < 3.0.0
- ocaml -> ocaml.5.1.0
    User requested <= 5.1.0
- ocaml-base-compiler -> ocaml-base-compiler.5.1.0
    User requested >= 4.04.1
    ocaml-base-compiler|ocaml-variants|ocaml-system|dkml-base-compiler ocaml-base-compiler requires >= 5.1.0~ & < 5.1.1~
- ocaml-variants -> (problem)
    Rejected candidates:
      ocaml-variants.5.3.0+trunk: In same conflict class (ocaml-core-compiler) as ocaml-base-compiler
      ocaml-variants.5.2.0+trunk: In same conflict class (ocaml-core-compiler) as ocaml-base-compiler
      ocaml-variants.5.1.2+trunk: In same conflict class (ocaml-core-compiler) as ocaml-base-compiler
      ocaml-variants.5.1.1+tsan: In same conflict class (ocaml-core-compiler) as ocaml-base-compiler
      ocaml-variants.5.1.1+options: In same conflict class (ocaml-core-compiler) as ocaml-base-compiler
      ...
- sexplib -> (problem)
    shared-block-ring 1.0.0 requires < 113.01.00
    Rejected candidates:
      sexplib.v0.16.0: Incompatible with restriction: < 113.01.00
      sexplib.v0.15.1: Incompatible with restriction: < 113.01.00
      sexplib.v0.15.0: Requires ocaml >= 4.08.0 & < 5.0
      sexplib.v0.14.0: Incompatible with restriction: < 113.01.00
      sexplib.v0.13.0: Incompatible with restriction: < 113.01.00
      ...
- shared-block-ring -> shared-block-ring.1.0.0
    User requested = 1.0.0