Package riot

Failed to find a solution:

no platform:
2024-03-27 17:24.59 [INFO] Solving for ocaml-base-compiler, ocaml,
                           riot using opam_repository_commit fe00df86c9b4d714ec1d1c3b5fad3b9485967f6e

2024-03-27 17:26.20 [INFO] base: eliminated all possibilities in 1.32 s

2024-03-27 17:26.20 [INFO] = base =

2024-03-27 17:26.20 [INFO] Can't find all required versions.
Selected: angstrom.0.16.0 base-bigarray.base base-domains.base base-nnp.base
          base-threads.base base-unix.base base64.3.5.1 bigstringaf.0.9.1
          bytestring.0.0.8 colors.0.0.1 conf-gmp.4 conf-gmp-powm-sec.3
          config.0.0.2 csexp.1.5.2 cstruct.6.2.0 domain-name.0.4.0
          dune.3.14.2 dune-configurator.3.14.2 duration.0.2.1 eqaf.0.9
          fmt.0.9.0 gen.1.1 gluon.0.0.8 gmap.0.3.0 hkdf.1.0.4 ipaddr.5.5.0
          libc.0.0.1 logs.0.7.0 macaddr.5.5.0 mirage-crypto.0.11.3
          mirage-crypto-ec.0.11.3 mirage-crypto-pk.0.11.3
          mirage-crypto-rng.0.11.3 mtime.2.0.0 ocaml-compiler-libs.v0.17.0
          ocaml-options-vanilla.1 ocaml-syntax-shims.1.0.0 ocamlbuild.0.14.3
          ocamlfind.1.9.6 pbkdf.1.2.0 ppx_derivers.1.2.1
          ppxlib.0.32.1~5.2preview ptime.1.1.0 rio.0.0.8 sedlex.3.2 seq.base
          sexplib0.v0.16.0 spices.0.0.2 stdlib-shims.0.3.0 stringext.1.6.0
          telemetry.0.0.1 topkg.1.0.7 tty.0.0.2 uri.4.4.0 uutf.1.0.3
          x509.0.16.5 zarith.1.13 riot&ocaml&ocaml-base-compiler ocaml
          base-domains ocaml ocaml-base-compiler
- asn1-combinators -> asn1-combinators.0.2.6
    x509 0.16.5 requires >= 0.2.0 & < 0.3.0
- ocaml -> (problem)
    User requested <= 5.1.0
    angstrom 0.16.0 requires >= 4.04.0
    asn1-combinators 0.2.6 requires >= 4.08.0
    bytestring 0.0.8 requires >= 5.1.1
    Rejected candidates:
      ocaml.5.1.0: Incompatible with restriction: >= 5.1.1
      ocaml.5.0.1: Incompatible with restriction: >= 5.1.1
      ocaml.5.0.0: Incompatible with restriction: >= 5.1.1
      ocaml.4.14.3: Incompatible with restriction: >= 5.1.1
      ocaml.4.14.2: Incompatible with restriction: >= 5.1.1
      ...
- ocaml-base-compiler -> ocaml-base-compiler.5.2.0~beta1
    User requested >= 4.04.1
- randomconv -> randomconv.0.1.3
    riot 0.0.8 requires >= 0.1.3 & < 0.2.0
- riot -> riot.0.0.8
    User requested = 0.0.8
- tls -> tls.0.17.3
    riot 0.0.8 requires >= 0.17.3 & < 0.17.4