Package ppx_typerep_conv

Failed to find a solution:

no platform:
2024-01-29 14:52.45 [INFO] Solving for ocaml-base-compiler, ocaml,
                           ppx_typerep_conv using opam_repository_commit 251c5edf2ecdd2541c324dacb931c3606ee71eeb

2024-01-29 14:52.51 [INFO] base: eliminated all possibilities in 2.49 s

2024-01-29 14:52.51 [INFO] = base =

2024-01-29 14:52.51 [INFO] Can't find all required versions.
Selected: base-ocamlbuild.base base-threads.base base-unix.base cppo.1.6.9
          cppo_ocamlbuild.1.6.9 dune.3.13.0 ocaml-config.3
          ocaml-secondary-compiler.4.08.1-1 ocamlbuild.0 ocamlfind.1.9.6
          ocamlfind-secondary.1.9.6 ppx_tools.5.0+4.02.0
          ppx_typerep_conv&ocaml&ocaml-base-compiler ocaml-base-compiler
          ocaml-base-compiler ocaml&ocamlfind-secondary
- ocaml -> ocaml.4.02.4
    User requested <= 5.1.0
    base-ocamlbuild base requires >= 3.10 & < 4.03
- ocaml-base-compiler -> (problem)
    User requested >= 4.04.1
    Rejected candidates:
      ocaml-base-compiler.5.1.1: Requires ocaml = 5.1.1
      ocaml-base-compiler.5.1.1~rc1: Requires ocaml = 5.1.1
      ocaml-base-compiler.5.1.0: Requires ocaml = 5.1.0
      ocaml-base-compiler.5.1.0~rc3: Requires ocaml = 5.1.0
      ocaml-base-compiler.5.1.0~rc2: Requires ocaml = 5.1.0
      ...
- ppx_core -> ppx_core.113.09.00
    ppx_driver 113.09.00 requires >= 113.09.00 & < 113.10.00
- ppx_deriving -> ppx_deriving.3.3
    ppx_type_conv 113.09.00 requires >= 3.0 & < 4.0
- ppx_driver -> ppx_driver.113.09.00
    ppx_type_conv 113.09.00 requires >= 113.09.00 & < 113.10.00
- ppx_optcomp -> ppx_optcomp.113.09.00
    ppx_driver 113.09.00 requires >= 113.09.00 & < 113.10.00
- ppx_type_conv -> ppx_type_conv.113.09.00
    ppx_typerep_conv 113.09.00 requires >= 113.09.00 & < 113.10.00
- ppx_typerep_conv -> ppx_typerep_conv.113.09.00
    User requested = 113.09.00