Package ppx_overload

Failed to find a solution:

no platform:
2024-01-29 14:50.14 [INFO] Solving for ocaml-base-compiler, ocaml,
                           ppx_overload using opam_repository_commit 251c5edf2ecdd2541c324dacb931c3606ee71eeb

2024-01-29 14:50.19 [INFO] base: eliminated all possibilities in 2.64 s

2024-01-29 14:50.19 [INFO] = base =

2024-01-29 14:50.19 [INFO] Can't find all required versions.
Selected: ocaml-config.3 ppx_overload&ocaml&ocaml-base-compiler
          ocaml-base-compiler ocaml-base-compiler
- ocaml -> ocaml.4.02.4
    User requested <= 5.1.0
    ppx_overload 1.0.0 requires >= 4.02.0 & < 4.03.0
- ocaml-base-compiler -> (problem)
    User requested >= 4.04.1
    Rejected candidates:
      ocaml-base-compiler.5.1.1: Requires ocaml = 5.1.1
      ocaml-base-compiler.5.1.1~rc1: Requires ocaml = 5.1.1
      ocaml-base-compiler.5.1.0: Requires ocaml = 5.1.0
      ocaml-base-compiler.5.1.0~rc3: Requires ocaml = 5.1.0
      ocaml-base-compiler.5.1.0~rc2: Requires ocaml = 5.1.0
      ...
- ppx_overload -> ppx_overload.1.0.0
    User requested = 1.0.0