Package orm

Failed to find a solution:

no platform:
2024-01-29 14:54.06 [INFO] Solving for ocaml-base-compiler, ocaml,
                           orm using opam_repository_commit 251c5edf2ecdd2541c324dacb931c3606ee71eeb

2024-01-29 14:54.12 [INFO] base: eliminated all possibilities in 2.95 s

2024-01-29 14:54.12 [INFO] = base =

2024-01-29 14:54.12 [INFO] Can't find all required versions.
Selected: base-num.base base-ocamlbuild.base camlp4.4.02.0-1modular-implicits
          conf-pkg-config.3 conf-sqlite3.1 conf-which.1 dyntype.0.9.0 num.0
          ocaml-config.3 ocamlbuild.0 ocamlfind.1.9.6
          orm&ocaml&ocaml-base-compiler ocaml-base-compiler
          ocaml-base-compiler
- ocaml -> ocaml.4.01.0
    User requested <= 5.1.0
    base-num base requires < 4.06.0
    base-ocamlbuild base requires >= 3.10 & < 4.03
    orm 0.6.4 requires <= 4.01.0
- ocaml-base-compiler -> (problem)
    User requested >= 4.04.1
    Rejected candidates:
      ocaml-base-compiler.5.1.1: Requires ocaml = 5.1.1
      ocaml-base-compiler.5.1.1~rc1: Requires ocaml = 5.1.1
      ocaml-base-compiler.5.1.0: Requires ocaml = 5.1.0
      ocaml-base-compiler.5.1.0~rc3: Requires ocaml = 5.1.0
      ocaml-base-compiler.5.1.0~rc2: Requires ocaml = 5.1.0
      ...
- ocaml-variants -> (problem)
    camlp4 4.02.0-1modular-implicits requires = 4.02.0+modular-implicits | = 4.02.1+modular-implicits-ber
    Rejected candidates:
      ocaml-variants.5.3.0+trunk: Incompatible with restriction: = 4.02.0+modular-implicits | = 4.02.1+modular-implicits-ber
      ocaml-variants.5.2.0+trunk: Incompatible with restriction: = 4.02.0+modular-implicits | = 4.02.1+modular-implicits-ber
      ocaml-variants.5.1.2+trunk: Incompatible with restriction: = 4.02.0+modular-implicits | = 4.02.1+modular-implicits-ber
      ocaml-variants.5.1.1+tsan: Incompatible with restriction: = 4.02.0+modular-implicits | = 4.02.1+modular-implicits-ber
      ocaml-variants.5.1.1+options: Incompatible with restriction: = 4.02.0+modular-implicits | = 4.02.1+modular-implicits-ber
      ...
- orm -> orm.0.6.4
    User requested = 0.6.4
- sqlite3 -> sqlite3.4.1.3
    orm 0.6.4 requires < 5.0.0
- type_conv -> (problem)
    dyntype 0.9.0 requires >= 108.07.00
    orm 0.6.4 requires <= 108.00.02
    Rejected candidates:
      type_conv.113.00.02: Incompatible with restriction: <= 108.00.02
      type_conv.113.00.01: Incompatible with restriction: <= 108.00.02
      type_conv.113.00.00: Incompatible with restriction: <= 108.00.02
      type_conv.112.01.02: Incompatible with restriction: <= 108.00.02
      type_conv.112.01.01: Incompatible with restriction: <= 108.00.02
      ...