Package opium

Failed to find a solution:

no platform:
2024-01-29 14:57.54 [INFO] Solving for ocaml-base-compiler, ocaml,
                           opium using opam_repository_commit 251c5edf2ecdd2541c324dacb931c3606ee71eeb

2024-01-29 14:58.00 [INFO] base: eliminated all possibilities in 2.84 s

2024-01-29 14:58.00 [INFO] = base =

2024-01-29 14:58.00 [INFO] Can't find all required versions.
Selected: angstrom.0.16.0 async.v0.16.0 async_kernel.v0.16.0
          async_rpc_kernel.v0.16.0 async_unix.v0.16.0 base.v0.16.3
          base-bigarray.base base-domains.base base-nnp.base
          base-threads.base base-unix.base base_bigstring.v0.16.0
          base_quickcheck.v0.16.0 bigstringaf.0.9.1 bin_prot.v0.16.0
          core.v0.16.2 core_kernel.v0.16.0 core_unix.v0.16.0 cow.2.5.0
          csexp.1.5.2 cstruct.6.2.0 dune.3.13.0 dune-build-info.3.13.0
          dune-configurator.3.13.0 expect_test_helpers_core.v0.16.0
          ezjsonm.1.3.0 fmt.0.9.0 hex.1.5.0 humane-re.0.1.1 int_repr.v0.16.0
          jane-street-headers.v0.16.0 jsonm.1.0.2 jst-config.v0.16.0
          oasis.0.4.11 ocaml-compiler-libs.v0.12.4 ocaml-config.3
          ocaml-options-vanilla.1 ocaml-syntax-shims.1.0.0
          ocaml_intrinsics.v0.16.0 ocamlbuild.0.14.3 ocamlfind.1.9.6
          omd.2.0.0~alpha4 ppx_assert.v0.16.0 ppx_base.v0.16.0
          ppx_bench.v0.16.0 ppx_bin_prot.v0.16.0 ppx_cold.v0.16.0
          ppx_compare.v0.16.0 ppx_custom_printf.v0.16.0 ppx_derivers.1.2.1
          ppx_disable_unused_warnings.v0.16.0 ppx_enumerate.v0.16.0
          ppx_expect.v0.16.0 ppx_fields_conv.v0.16.0
          ppx_fixed_literal.v0.16.0 ppx_globalize.v0.16.0 ppx_hash.v0.16.0
          ppx_here.v0.16.0 ppx_ignore_instrumentation.v0.16.0
          ppx_inline_test.v0.16.1 ppx_jane.v0.16.0 ppx_let.v0.16.0
          ppx_log.v0.16.0 ppx_module_timer.v0.16.0 ppx_optcomp.v0.16.0
          ppx_optional.v0.16.0 ppx_pipebang.v0.16.0 ppx_sexp_conv.v0.16.0
          ppx_sexp_message.v0.16.0 ppx_sexp_value.v0.16.0 ppx_stable.v0.16.0
          ppx_stable_witness.v0.16.0 ppx_string.v0.16.0 ppx_tydi.v0.16.0
          ppx_typerep_conv.v0.16.0 ppx_variants_conv.v0.16.0 ppxlib.0.31.0
          protocol_version_header.v0.16.0 re.1.11.0 seq.base
          sexp_pretty.v0.16.0 sexplib0.v0.16.0 spawn.v0.15.1
          splittable_random.v0.16.0 stdio.v0.16.0 stdlib-shims.0.3.0
          stringext.1.6.0 textutils.v0.16.0 textutils_kernel.v0.16.0
          time_now.v0.16.0 timezone.v0.16.0 topkg.1.0.7 typerep.v0.16.0
          uri.4.4.0 uucp.15.1.0 uunf.15.1.0 uutf.1.0.3 variantslib.v0.16.0
          xmlm.1.4.0 opium&ocaml&ocaml-base-compiler ocaml-base-compiler
          ocaml-base-compiler ocaml base-domains ocaml ocaml-base-compiler
- cohttp -> (problem)
    opium 0.10.0 requires >= 0.10.0 & < 0.12.0
    Rejected candidates:
      cohttp.6.0.0~beta2: Incompatible with restriction: >= 0.10.0 & < 0.12.0
      cohttp.6.0.0~alpha2: Incompatible with restriction: >= 0.10.0 & < 0.12.0
      cohttp.6.0.0~alpha1: Incompatible with restriction: >= 0.10.0 & < 0.12.0
      cohttp.6.0.0~alpha0: Incompatible with restriction: >= 0.10.0 & < 0.12.0
      cohttp.5.3.1: Incompatible with restriction: >= 0.10.0 & < 0.12.0
      ...
- fieldslib -> (problem)
    core v0.16.2 requires >= v0.16 & < v0.17
    opium 0.10.0 requires < 113.01.00
    Rejected candidates:
      fieldslib.v0.16.0: Incompatible with restriction: < 113.01.00
      fieldslib.v0.15.0: Incompatible with restriction: >= v0.16 & < v0.17
      fieldslib.v0.14.0: Incompatible with restriction: >= v0.16 & < v0.17
      fieldslib.v0.13.0: Incompatible with restriction: >= v0.16 & < v0.17
      fieldslib.v0.12.0: Incompatible with restriction: >= v0.16 & < v0.17
      ...
- ocaml -> ocaml.5.1.0
    User requested <= 5.1.0
- ocaml-base-compiler -> ocaml-base-compiler.5.1.0
    User requested >= 4.04.1
    ocaml-base-compiler|ocaml-variants|ocaml-system|dkml-base-compiler ocaml-base-compiler requires >= 5.1.0~ & < 5.1.1~
- ocamlify -> (problem)
    Rejected candidates:
      ocamlify.0.0.1: Requires ocaml < 5.0
- ocamlmod -> (problem)
    Rejected candidates:
      ocamlmod.0.0.9: Requires ocaml < 5.0
      ocamlmod.0.0.8: Requires ocaml < 5.0
      ocamlmod.0.0.7: Requires ocaml < 4.06.0
      ocamlmod.0.0.4: Requires ocaml < 4.06.0
      ocamlmod.0.0.3: Requires ocaml < 4.06.0
- opium -> opium.0.10.0
    User requested = 0.10.0
- sexplib -> (problem)
    core v0.16.2 requires >= v0.16 & < v0.17
    opium 0.10.0 requires < 113.01.00
    Rejected candidates:
      sexplib.v0.16.0: Incompatible with restriction: < 113.01.00
      sexplib.v0.15.1: Incompatible with restriction: >= v0.16 & < v0.17
      sexplib.v0.15.0: Incompatible with restriction: >= v0.16 & < v0.17
      sexplib.v0.14.0: Incompatible with restriction: >= v0.16 & < v0.17
      sexplib.v0.13.0: Incompatible with restriction: >= v0.16 & < v0.17
      ...