Package ocaml-variants

Failed to find a solution:

no platform:
2024-05-10 09:29.28 [INFO] Solving for ocaml-base-compiler, ocaml,
                           ocaml-variants using opam_repository_commit 20baedeee4da8e9eb9e3ea43f5dcc631e88de9e6

2024-05-10 09:29.34 [INFO] base: eliminated all possibilities in 2.34 s

2024-05-10 09:29.34 [INFO] = base =

2024-05-10 09:29.34 [INFO] Can't find all required versions.
Selected: base-bigarray.base base-threads.base base-unix.base ocaml-config.3
          ocaml-variants&ocaml&ocaml-base-compiler ocaml-base-compiler
          ocaml-base-compiler
- ocaml -> ocaml.4.05.1
    User requested <= 5.1.1
    ocaml-variants 4.05.1+trunk requires = 4.05.1
- ocaml-base-compiler -> (problem)
    User requested >= 4.04.1
    Rejected candidates:
      ocaml-base-compiler.5.2.0~rc1: In same conflict class (ocaml-core-compiler) as ocaml-variants
      ocaml-base-compiler.5.2.0~beta2: In same conflict class (ocaml-core-compiler) as ocaml-variants
      ocaml-base-compiler.5.2.0~beta1: In same conflict class (ocaml-core-compiler) as ocaml-variants
      ocaml-base-compiler.5.2.0~alpha1: In same conflict class (ocaml-core-compiler) as ocaml-variants
      ocaml-base-compiler.5.1.1: In same conflict class (ocaml-core-compiler) as ocaml-variants
      ...
- ocaml-variants -> ocaml-variants.4.05.1+trunk
    User requested = 4.05.1+trunk