Package ocaml-variants

Failed to find a solution:

no platform:
2024-05-10 09:29.35 [INFO] Solving for ocaml-base-compiler, ocaml,
                           ocaml-variants using opam_repository_commit 20baedeee4da8e9eb9e3ea43f5dcc631e88de9e6

2024-05-10 09:29.41 [INFO] base: eliminated all possibilities in 2.49 s

2024-05-10 09:29.41 [INFO] = base =

2024-05-10 09:29.41 [INFO] Can't find all required versions.
Selected: base-bigarray.base base-domains.base base-nnp.base
          base-threads.base base-unix.base ocaml-config.3
          ocaml-options-vanilla.1 ocaml-variants&ocaml&ocaml-base-compiler
          ocaml-base-compiler ocaml-base-compiler ocaml base-domains
          ocaml-base-compiler
- ocaml -> ocaml.5.1.1
    User requested <= 5.1.1
- ocaml-base-compiler -> ocaml-base-compiler.5.1.1
    User requested >= 4.04.1
    ocaml-base-compiler|ocaml-variants|ocaml-system|dkml-base-compiler ocaml-base-compiler requires >= 5.1.1~ & < 5.1.2~
- ocaml-variants -> (problem)
    User requested = 4.00.1+annot
    No usable implementations:
      ocaml-variants.5.3.0+trunk: Rejected by user-specified constraint ocaml-variants (= 4.00.1+annot)
      ocaml-variants.5.2.0+trunk: Rejected by user-specified constraint ocaml-variants (= 4.00.1+annot)
      ocaml-variants.5.2.0~rc1+options: Rejected by user-specified constraint ocaml-variants (= 4.00.1+annot)
      ocaml-variants.5.2.0~beta2+options: Rejected by user-specified constraint ocaml-variants (= 4.00.1+annot)
      ocaml-variants.5.2.0~beta1+options: Rejected by user-specified constraint ocaml-variants (= 4.00.1+annot)
      ...