Package ocaml-system

Failed to find a solution:

no platform:
2024-05-10 09:28.42 [INFO] Solving for ocaml-base-compiler, ocaml,
                           ocaml-system using opam_repository_commit 20baedeee4da8e9eb9e3ea43f5dcc631e88de9e6

2024-05-10 09:28.47 [INFO] base: eliminated all possibilities in 2.37 s

2024-05-10 09:28.47 [INFO] = base =

2024-05-10 09:28.47 [INFO] Can't find all required versions.
Selected: base-bigarray.base base-domains.base base-nnp.base
          base-threads.base base-unix.base ocaml-config.3
          ocaml-options-vanilla.1 ocaml-system&ocaml&ocaml-base-compiler
          ocaml-base-compiler ocaml-base-compiler ocaml base-domains
          ocaml-base-compiler
- ocaml -> ocaml.5.1.1
    User requested <= 5.1.1
- ocaml-base-compiler -> ocaml-base-compiler.5.1.1
    User requested >= 4.04.1
    ocaml-base-compiler|ocaml-variants|ocaml-system|dkml-base-compiler ocaml-base-compiler requires >= 5.1.1~ & < 5.1.2~
- ocaml-system -> (problem)
    User requested = 5.1.0
    No usable implementations:
      ocaml-system.5.1.1: Rejected by user-specified constraint ocaml-system (= 5.1.0)
      ocaml-system.5.1.0: Availability condition not satisfied
      ocaml-system.5.0.0: Rejected by user-specified constraint ocaml-system (= 5.1.0)
      ocaml-system.4.14.2: Rejected by user-specified constraint ocaml-system (= 5.1.0)
      ocaml-system.4.14.1: Rejected by user-specified constraint ocaml-system (= 5.1.0)
      ...