Package ocaml-src

Failed to find a solution:

no platform:
2024-05-13 10:32.04 [INFO] Solving for ocaml-base-compiler, ocaml,
                           ocaml-src using opam_repository_commit 76d09264e920a27527de605cc64ef1d28ec353cd

2024-05-13 10:33.24 [INFO] base: eliminated all possibilities in 1.27 s

2024-05-13 10:33.24 [INFO] = base =

2024-05-13 10:33.24 [INFO] Can't find all required versions.
Selected: base-bigarray.base base-domains.base base-nnp.base
          base-threads.base base-unix.base ocaml-options-vanilla.1
          ocaml-src&ocaml&ocaml-base-compiler ocaml base-domains
          ocaml-base-compiler
- ocaml -> (problem)
    User requested <= 5.1.1
    ocaml-base-compiler 5.2.0 requires = 5.2.0
    Rejected candidates:
      ocaml.5.1.1: Incompatible with restriction: = 5.2.0
      ocaml.5.1.0: Incompatible with restriction: = 5.2.0
      ocaml.5.0.1: Incompatible with restriction: = 5.2.0
      ocaml.5.0.0: Incompatible with restriction: = 5.2.0
      ocaml.4.14.3: Incompatible with restriction: = 5.2.0
      ...
- ocaml-base-compiler -> ocaml-base-compiler.5.2.0
    User requested >= 4.04.1
- ocaml-src -> ocaml-src.5.2.0
    User requested = 5.2.0