Package ocaml-options-only-nnp

Failed to find a solution:

no platform:
2024-05-10 09:28.47 [INFO] Solving for ocaml-base-compiler, ocaml,
                           ocaml-options-only-nnp using opam_repository_commit 20baedeee4da8e9eb9e3ea43f5dcc631e88de9e6

2024-05-10 09:28.53 [INFO] base: eliminated all possibilities in 2.64 s

2024-05-10 09:28.53 [INFO] = base =

2024-05-10 09:28.53 [INFO] Can't find all required versions.
Selected: base-bigarray.base base-domains.base base-nnp.base
          base-threads.base base-unix.base ocaml-config.3 ocaml-option-nnp.1
          ocaml-options-only-nnp&ocaml&ocaml-base-compiler
          ocaml-base-compiler ocaml-base-compiler base-domains
- ocaml -> ocaml.4.14.3
    User requested <= 5.1.1
    ocaml-variants 4.14.3+trunk requires = 4.14.3
- ocaml-base-compiler -> (problem)
    User requested >= 4.04.1
    Rejected candidates:
      ocaml-base-compiler.5.2.0~rc1: In same conflict class (ocaml-core-compiler) as ocaml-variants
      ocaml-base-compiler.5.2.0~beta2: In same conflict class (ocaml-core-compiler) as ocaml-variants
      ocaml-base-compiler.5.2.0~beta1: In same conflict class (ocaml-core-compiler) as ocaml-variants
      ocaml-base-compiler.5.2.0~alpha1: In same conflict class (ocaml-core-compiler) as ocaml-variants
      ocaml-base-compiler.5.1.1: In same conflict class (ocaml-core-compiler) as ocaml-variants
      ...
- ocaml-options-only-nnp -> ocaml-options-only-nnp.1
    User requested = 1
- ocaml-variants -> ocaml-variants.4.14.3+trunk
    ocaml-option-nnp 1 requires >= 4.12.0~ & < 5.0.0~~
- ocaml|ocaml-variants -> (problem)
    Rejected candidates:
      ocaml: Requires ocaml >= 5.0
      ocaml-variants: Requires ocaml-variants = 4.14.0+domains | = 4.12.0+domains+effects | = 4.12.0+domains | = 4.10.0+multicore | = 4.10.0+multicore+no-effect-syntax | = 4.06.1+multicore