Package ocaml-migrate-parsetree

Failed to find a solution:

no platform:
2024-01-29 15:11.35 [INFO] Solving for ocaml-base-compiler, ocaml,
                           ocaml-migrate-parsetree using opam_repository_commit 251c5edf2ecdd2541c324dacb931c3606ee71eeb

2024-01-29 15:11.40 [INFO] base: eliminated all possibilities in 2.35 s

2024-01-29 15:11.40 [INFO] = base =

2024-01-29 15:11.40 [INFO] Can't find all required versions.
Selected: base-threads.base base-unix.base dune.3.13.0 ocaml-config.3
          ppx_derivers.1.2.1 result.1.5
          ocaml-migrate-parsetree&ocaml&ocaml-base-compiler
          ocaml-base-compiler ocaml-base-compiler ocaml
- ocaml -> ocaml.4.08.2
    User requested <= 5.1.0
    ocaml-migrate-parsetree 1.3.0~4.08.0+beta3 requires >= 4.02.3 & < 4.09.0
- ocaml-base-compiler -> (problem)
    User requested >= 4.04.1
    Rejected candidates:
      ocaml-base-compiler.5.1.1: Requires ocaml = 5.1.1
      ocaml-base-compiler.5.1.1~rc1: Requires ocaml = 5.1.1
      ocaml-base-compiler.5.1.0: Requires ocaml = 5.1.0
      ocaml-base-compiler.5.1.0~rc3: Requires ocaml = 5.1.0
      ocaml-base-compiler.5.1.0~rc2: Requires ocaml = 5.1.0
      ...
- ocaml-migrate-parsetree -> ocaml-migrate-parsetree.1.3.0~4.08.0+beta3
    User requested = 1.3.0~4.08.0+beta3
- ocaml-variants -> (problem)
    ocaml-migrate-parsetree 1.3.0~4.08.0+beta3 requires = 4.08.0+beta3
    Rejected candidates:
      ocaml-variants.5.3.0+trunk: Incompatible with restriction: = 4.08.0+beta3
      ocaml-variants.5.2.0+trunk: Incompatible with restriction: = 4.08.0+beta3
      ocaml-variants.5.1.2+trunk: Incompatible with restriction: = 4.08.0+beta3
      ocaml-variants.5.1.1+tsan: Incompatible with restriction: = 4.08.0+beta3
      ocaml-variants.5.1.1+options: Incompatible with restriction: = 4.08.0+beta3
      ...