Package ocaml-lua

Failed to find a solution:

no platform:
2024-01-29 14:49.03 [INFO] Solving for ocaml-base-compiler, ocaml,
                           ocaml-lua using opam_repository_commit 251c5edf2ecdd2541c324dacb931c3606ee71eeb

2024-01-29 14:49.09 [INFO] base: eliminated all possibilities in 2.51 s

2024-01-29 14:49.09 [INFO] = base =

2024-01-29 14:49.09 [INFO] Can't find all required versions.
Selected: base-ocamlbuild.base ocaml-config.3 ocamlbuild.0 ocamlfind.1.9.6
          ocaml-lua&ocaml&ocaml-base-compiler ocaml-base-compiler
          ocaml-base-compiler
- ocaml -> ocaml.4.02.4
    User requested <= 5.1.0
    base-ocamlbuild base requires >= 3.10 & < 4.03
- ocaml-base-compiler -> (problem)
    User requested >= 4.04.1
    Rejected candidates:
      ocaml-base-compiler.5.1.1: Requires ocaml = 5.1.1
      ocaml-base-compiler.5.1.1~rc1: Requires ocaml = 5.1.1
      ocaml-base-compiler.5.1.0: Requires ocaml = 5.1.0
      ocaml-base-compiler.5.1.0~rc3: Requires ocaml = 5.1.0
      ocaml-base-compiler.5.1.0~rc2: Requires ocaml = 5.1.0
      ...
- ocaml-lua -> ocaml-lua.1.4
    User requested = 1.4