Package ocaml-config

Failed to find a solution:

no platform:
2024-05-10 09:28.41 [INFO] Solving for ocaml-base-compiler, ocaml,
                           ocaml-config using opam_repository_commit 20baedeee4da8e9eb9e3ea43f5dcc631e88de9e6

2024-05-10 09:28.47 [INFO] base: eliminated all possibilities in 2.60 s

2024-05-10 09:28.47 [INFO] = base =

2024-05-10 09:28.47 [INFO] Can't find all required versions.
Selected: ocaml-config&ocaml&ocaml-base-compiler ocaml-base-compiler
          ocaml-base-compiler
- ocaml -> ocaml.4.11.3
    User requested <= 5.1.1
- ocaml-base-compiler -> (problem)
    User requested >= 4.04.1
    Rejected candidates:
      ocaml-base-compiler.5.2.0~rc1: Requires ocaml = 5.2.0
      ocaml-base-compiler.5.2.0~beta2: Requires ocaml = 5.2.0
      ocaml-base-compiler.5.2.0~beta1: Requires ocaml = 5.2.0
      ocaml-base-compiler.5.2.0~alpha1: Requires ocaml = 5.2.0
      ocaml-base-compiler.5.1.1: Requires ocaml = 5.1.1
      ...
- ocaml-config -> ocaml-config.0
    User requested = 0