Package mirage

Failed to find a solution:

no platform:
2024-01-29 15:09.26 [INFO] Solving for ocaml-base-compiler, ocaml,
                           mirage using opam_repository_commit 251c5edf2ecdd2541c324dacb931c3606ee71eeb

2024-01-29 15:09.32 [INFO] base: eliminated all possibilities in 2.60 s

2024-01-29 15:09.32 [INFO] = base =

2024-01-29 15:09.32 [INFO] Can't find all required versions.
Selected: base-bigarray.base base-bytes.base base-domains.base base-nnp.base
          base-threads.base base-unix.base conf-pkg-config.3 cppo.1.6.9
          csexp.1.5.2 cstruct.6.2.0 domain-name.0.4.0 dune.3.13.0
          dune-configurator.3.13.0 fmt.0.9.0 io-page.3.0.0 ipaddr.5.5.0
          lwt.5.7.0 macaddr.5.5.0 ocaml-config.3 ocaml-options-vanilla.1
          ocamlbuild.0.14.3 ocamlfind.1.9.6 ocplib-endian.1.2 re.1.11.0
          seq.base topkg.1.0.7 mirage&ocaml&ocaml-base-compiler
          ocaml-base-compiler ocaml-base-compiler ocaml base-domains ocaml
          ocaml-base-compiler
- cmdliner -> (problem)
    mirage 2.2.0 requires >= 0.9.2 & < 1.0
    Rejected candidates:
      cmdliner.1.2.0: Incompatible with restriction: >= 0.9.2 & < 1.0
      cmdliner.1.1.1: Incompatible with restriction: >= 0.9.2 & < 1.0
      cmdliner.1.1.0: Incompatible with restriction: >= 0.9.2 & < 1.0
      cmdliner.1.0.4: Incompatible with restriction: >= 0.9.2 & < 1.0
      cmdliner.1.0.3: Requires ocaml >= 4.03.0 & < 5.0
      ...
- crunch -> crunch.2.2.0
    mirage 2.2.0 requires >= 1.2.2 & < 3.0.0
- mirage -> mirage.2.2.0
    User requested = 2.2.0
- mirage-types -> (problem)
    mirage 2.2.0 requires >= 2.2.0 & < 2.3.0
    Rejected candidates:
      mirage-types.3.10.8: Incompatible with restriction: >= 2.2.0 & < 2.3.0
      mirage-types.3.10.7: Incompatible with restriction: >= 2.2.0 & < 2.3.0
      mirage-types.3.10.6: Incompatible with restriction: >= 2.2.0 & < 2.3.0
      mirage-types.3.10.5: Incompatible with restriction: >= 2.2.0 & < 2.3.0
      mirage-types.3.10.4: Incompatible with restriction: >= 2.2.0 & < 2.3.0
      ...
- ocaml -> ocaml.5.1.0
    User requested <= 5.1.0
- ocaml-base-compiler -> ocaml-base-compiler.5.1.0
    User requested >= 4.04.1
    ocaml-base-compiler|ocaml-variants|ocaml-system|dkml-base-compiler ocaml-base-compiler requires >= 5.1.0~ & < 5.1.1~
- sexplib -> (problem)
    mirage 2.2.0 requires < 113.01.00
    Rejected candidates:
      sexplib.v0.16.0: Incompatible with restriction: < 113.01.00
      sexplib.v0.15.1: Incompatible with restriction: < 113.01.00
      sexplib.v0.15.0: Incompatible with restriction: < 113.01.00
      sexplib.v0.14.0: Incompatible with restriction: < 113.01.00
      sexplib.v0.13.0: Incompatible with restriction: < 113.01.00
      ...