Package mirage-tc

Failed to find a solution:

no platform:
2024-01-29 14:50.42 [INFO] Solving for ocaml-base-compiler, ocaml,
                           mirage-tc using opam_repository_commit 251c5edf2ecdd2541c324dacb931c3606ee71eeb

2024-01-29 14:50.48 [INFO] base: eliminated all possibilities in 3.12 s

2024-01-29 14:50.48 [INFO] = base =

2024-01-29 14:50.48 [INFO] Can't find all required versions.
Selected: base.v0.16.3 base-bigarray.base base-domains.base base-nnp.base
          base-threads.base base-unix.base bigarray-compat.1.1.0
          bin_prot.v0.16.0 csexp.1.5.2 dune-configurator.3.13.0
          fieldslib.v0.16.0 jbuilder.transition mstruct.1.4.0 num.1.5
          ocaml-compiler-libs.v0.12.4 ocaml-config.3 ocaml-options-vanilla.1
          ocamlbuild.0.14.3 parsexp.v0.16.0 ppx_compare.v0.16.0
          ppx_custom_printf.v0.16.0 ppx_derivers.1.2.1
          ppx_fields_conv.v0.16.0 ppx_optcomp.v0.16.0 ppx_sexp_conv.v0.16.0
          ppx_stable_witness.v0.16.0 ppx_variants_conv.v0.16.0 ppxlib.0.31.0
          sexplib.v0.16.0 sexplib0.v0.16.0 stdio.v0.16.0 stdlib-shims.0.3.0
          variantslib.v0.16.0 mirage-tc&ocaml&ocaml-base-compiler
          ocaml-base-compiler ocaml-base-compiler ocaml base-domains
          ocaml-base-compiler
- cstruct -> cstruct.6.0.1
    mstruct 1.4.0 requires >= 2.4.0 & < 6.1.0
- dune -> (problem)
    base v0.16.3 requires >= 2.0.0
    csexp 1.5.2 requires >= 3.4
    Rejected candidates:
      dune.3.13.0: Requires jbuilder not(= transition)
      dune.3.12.2: Requires jbuilder not(= transition)
      dune.3.12.1: Requires jbuilder not(= transition)
      dune.3.11.1: Requires jbuilder not(= transition)
      dune.3.11.0: Requires jbuilder not(= transition)
      ...
- ezjsonm -> (problem)
    mirage-tc 0.2.0 requires >= 0.3.0 & < 0.4.0
    Rejected candidates:
      ezjsonm.1.3.0: Incompatible with restriction: >= 0.3.0 & < 0.4.0
      ezjsonm.1.2.0: Incompatible with restriction: >= 0.3.0 & < 0.4.0
      ezjsonm.1.1.0: Incompatible with restriction: >= 0.3.0 & < 0.4.0
      ezjsonm.1.0.0: Incompatible with restriction: >= 0.3.0 & < 0.4.0
      ezjsonm.0.6.0: Incompatible with restriction: >= 0.3.0 & < 0.4.0
      ...
- mirage-tc -> mirage-tc.0.2.0
    User requested = 0.2.0
- ocaml -> ocaml.5.1.0
    User requested <= 5.1.0
- ocaml-base-compiler -> ocaml-base-compiler.5.1.0
    User requested >= 4.04.1
    ocaml-base-compiler|ocaml-variants|ocaml-system|dkml-base-compiler ocaml-base-compiler requires >= 5.1.0~ & < 5.1.1~