Package mirage-qubes-ipv4

Failed to find a solution:

no platform:
2024-06-29 08:31.20 [INFO] Solving for ocaml-base-compiler, ocaml,
                           mirage-qubes-ipv4 using opam_repository_commit 75e85d5bb77f27fae869788623c85b5fe8b7ff40

2024-06-29 08:33.03 [INFO] base: eliminated all possibilities in 1.30 s

2024-06-29 08:33.03 [INFO] = base =

2024-06-29 08:33.03 [INFO] Can't find all required versions.
Selected: arp.3.1.1 base-bigarray.base base-bytes.base base-domains.base
          base-nnp.base base-threads.base base-unix.base cmdliner.1.3.0
          cppo.1.6.9 csexp.1.5.2 cstruct.6.2.0 cstruct-lwt.6.2.0
          domain-name.0.4.0 dune.3.16.0 dune-configurator.3.16.0
          duration.0.2.1 ethernet.3.2.0 fmt.0.9.0 host-arch-x86_64.1
          ipaddr.5.6.0 ipaddr-cstruct.5.6.0 logs.0.7.0 lru.0.3.1 lwt.5.7.0
          lwt-dllist.1.0.1 macaddr.5.6.0 macaddr-cstruct.5.6.0 metrics.0.4.1
          mirage-clock.4.2.0 mirage-flow.4.0.2 mirage-net.4.0.0
          mirage-time.3.0.0 ocaml-config.3 ocaml-options-vanilla.1
          ocamlbuild.0.14.3 ocamlfind.1.9.6 ocplib-endian.1.2 psq.0.2.1
          seq.base topkg.1.0.7 mirage-qubes-ipv4&ocaml&ocaml-base-compiler
          ocaml ocaml-base-compiler ocaml-base-compiler system-mingw ocaml
          base-domains ocaml-base-compiler
- mirage-qubes -> (problem)
    mirage-qubes-ipv4 0.9.4 requires = 0.9.4
    Rejected candidates:
      mirage-qubes.0.10.0: Incompatible with restriction: = 0.9.4
      mirage-qubes.0.9.5: Incompatible with restriction: = 0.9.4
      mirage-qubes.0.9.3: Incompatible with restriction: = 0.9.4
      mirage-qubes.0.9.2: Incompatible with restriction: = 0.9.4
      mirage-qubes.0.9.1: Requires cstruct >= 2.2.0 & < 6.1.0
      ...
- mirage-qubes-ipv4 -> mirage-qubes-ipv4.0.9.4
    User requested = 0.9.4
- mirage-random -> mirage-random.3.0.0
    tcpip 8.0.2 requires >= 2.0.0 & < 4.0.0
- ocaml -> ocaml.5.1.1
    User requested <= 5.1.1
- ocaml-base-compiler -> ocaml-base-compiler.5.1.1
    User requested >= 4.04.1
    ocaml-base-compiler|ocaml-variants|ocaml-system|dkml-base-compiler ocaml-base-compiler requires >= 5.1.1~ & < 5.1.2~
- randomconv -> randomconv.0.1.3
    tcpip 8.0.2 requires < 0.2.0
- system-mingw -> (problem)
    No usable implementations:
      system-mingw.1: Availability condition not satisfied
- tcpip -> tcpip.8.0.2
    mirage-qubes-ipv4 0.9.4 requires >= 7.0.0 & < 8.1.0