Package mirage-console-xen

Failed to find a solution:

no platform:
2024-01-29 15:11.36 [INFO] Solving for ocaml-base-compiler, ocaml,
                           mirage-console-xen using opam_repository_commit 251c5edf2ecdd2541c324dacb931c3606ee71eeb

2024-01-29 15:11.42 [INFO] base: eliminated all possibilities in 2.59 s

2024-01-29 15:11.42 [INFO] = base =

2024-01-29 15:11.42 [INFO] Can't find all required versions.
Selected: base-bigarray.base base-domains.base base-nnp.base
          base-threads.base base-unix.base ocaml-config.3
          ocaml-options-vanilla.1
          mirage-console-xen&ocaml&ocaml-base-compiler ocaml-base-compiler
          ocaml-base-compiler ocaml base-domains ocaml-base-compiler
- mirage-console-xen -> (problem)
    User requested = 2.3.5
    No usable implementations:
      mirage-console-xen.5.1.0: Rejected by user-specified constraint mirage-console-xen (= 2.3.5)
      mirage-console-xen.5.0.0: Rejected by user-specified constraint mirage-console-xen (= 2.3.5)
      mirage-console-xen.4.0.0: Rejected by user-specified constraint mirage-console-xen (= 2.3.5)
      mirage-console-xen.3.0.2: Rejected by user-specified constraint mirage-console-xen (= 2.3.5)
      mirage-console-xen.3.0.1: Rejected by user-specified constraint mirage-console-xen (= 2.3.5)
      ...
- ocaml -> ocaml.5.1.0
    User requested <= 5.1.0
- ocaml-base-compiler -> ocaml-base-compiler.5.1.0
    User requested >= 4.04.1
    ocaml-base-compiler|ocaml-variants|ocaml-system|dkml-base-compiler ocaml-base-compiler requires >= 5.1.0~ & < 5.1.1~