Package merlin

Failed to find a solution:

no platform:
2024-06-24 13:24.25 [INFO] Solving for ocaml-base-compiler, ocaml,
                           merlin using opam_repository_commit 795f80f1b5a00cb2eea32a4d4e5d8377fa125d62

2024-06-24 13:25.50 [INFO] base: eliminated all possibilities in 1.31 s

2024-06-24 13:25.50 [INFO] = base =

2024-06-24 13:25.50 [INFO] Can't find all required versions.
Selected: base-bigarray.base base-domains.base base-nnp.base
          base-threads.base base-unix.base csexp.1.5.2 dot-merlin-reader.5.1
          dune.3.16.0 host-arch-x86_64.1 merlin-lib.5.1-502 ocaml-index.1.0
          ocaml-options-vanilla.1 ocamlfind.1.9.6 seq.base yojson.2.2.1
          merlin&ocaml&ocaml-base-compiler system-mingw ocaml base-domains
          ocaml ocaml-base-compiler
- merlin -> merlin.5.1-502
    User requested = 5.1-502
- ocaml -> (problem)
    User requested <= 5.1.1
    csexp 1.5.2 requires >= 4.03.0
    dot-merlin-reader 5.1 requires >= 5.0
    merlin 5.1-502 requires >= 5.2 & < 5.3
    Rejected candidates:
      ocaml.5.1.1: Incompatible with restriction: >= 5.2 & < 5.3
      ocaml.5.1.0: Incompatible with restriction: >= 5.2 & < 5.3
      ocaml.5.0.1: Incompatible with restriction: >= 5.2 & < 5.3
      ocaml.5.0.0: Incompatible with restriction: >= 5.2 & < 5.3
      ocaml.4.14.3: Incompatible with restriction: >= 5.0
      ...
- ocaml-base-compiler -> ocaml-base-compiler.5.2.0
    User requested >= 4.04.1
- system-mingw -> (problem)
    No usable implementations:
      system-mingw.1: Availability condition not satisfied