Package malfunction

Failed to find a solution:

no platform:
2024-05-13 10:32.04 [INFO] Solving for ocaml-base-compiler, ocaml,
                           malfunction using opam_repository_commit 76d09264e920a27527de605cc64ef1d28ec353cd

2024-05-13 10:33.24 [INFO] base: eliminated all possibilities in 1.28 s

2024-05-13 10:33.24 [INFO] = base =

2024-05-13 10:33.24 [INFO] Can't find all required versions.
Selected: base-bigarray.base base-domains.base base-nnp.base
          base-threads.base base-unix.base conf-gmp.4 cppo.1.6.9
          jbuilder.transition ocaml-config.3 ocaml-options-vanilla.1
          ocamlfind.1.9.6 zarith.1.13 malfunction&ocaml&ocaml-base-compiler
          ocaml-base-compiler ocaml-base-compiler ocaml base-domains
          ocaml-base-compiler
- base-flambda -> (problem)
    No known implementations at all
- dune -> (problem)
    cppo 1.6.9 requires >= 1.10
    Rejected candidates:
      dune.3.15.2: Requires jbuilder not(= transition)
      dune.3.15.0: Requires jbuilder not(= transition)
      dune.3.14.2: Requires jbuilder not(= transition)
      dune.3.14.0: Requires jbuilder not(= transition)
      dune.3.13.1: Requires jbuilder not(= transition)
      ...
- malfunction -> malfunction.0.2
    User requested = 0.2
- ocaml -> ocaml.5.1.1
    User requested <= 5.1.1
- ocaml-base-compiler -> ocaml-base-compiler.5.1.1
    User requested >= 4.04.1
    ocaml-base-compiler|ocaml-variants|ocaml-system|dkml-base-compiler ocaml-base-compiler requires >= 5.1.1~ & < 5.1.2~
- ocaml-variants -> (problem)
    Rejected candidates:
      ocaml-variants.5.3.0+trunk: In same conflict class (ocaml-core-compiler) as ocaml-base-compiler
      ocaml-variants.5.2.1+trunk: In same conflict class (ocaml-core-compiler) as ocaml-base-compiler
      ocaml-variants.5.2.0+options: In same conflict class (ocaml-core-compiler) as ocaml-base-compiler
      ocaml-variants.5.2.0~rc1+options: In same conflict class (ocaml-core-compiler) as ocaml-base-compiler
      ocaml-variants.5.2.0~beta2+options: In same conflict class (ocaml-core-compiler) as ocaml-base-compiler
      ...