Package javalib

Failed to find a solution:

no platform:
2024-05-13 09:29.44 [INFO] Solving for ocaml-base-compiler, ocaml,
                           javalib using opam_repository_commit c3d26a5899c5e309b6616d4e3cb57c3fe40ea0a5

2024-05-13 09:31.06 [INFO] base: eliminated all possibilities in 1.44 s

2024-05-13 09:31.06 [INFO] = base =

2024-05-13 09:31.06 [INFO] Can't find all required versions.
Selected: ocaml-config.3 ocamlfind.1.9.6 javalib&ocaml&ocaml-base-compiler
          extlib ocaml-base-compiler ocaml-base-compiler
- camlzip -> (problem)
    javalib 2.2.2 requires = 1.04
    Rejected candidates:
      camlzip.1.11: Incompatible with restriction: = 1.04
      camlzip.1.10: Incompatible with restriction: = 1.04
      camlzip.1.09: Incompatible with restriction: = 1.04
      camlzip.1.08: Incompatible with restriction: = 1.04
      camlzip.1.07: Incompatible with restriction: = 1.04
      ...
- extlib -> (problem)
    extlib|extlib-compat extlib requires <= 1.6.0
    Rejected candidates:
      extlib.1.7.9: Incompatible with restriction: <= 1.6.0
      extlib.1.7.8: Incompatible with restriction: <= 1.6.0
      extlib.1.7.7-1: Incompatible with restriction: <= 1.6.0
      extlib.1.7.7: Requires ocaml < 4.12.0
      extlib.1.7.6: Requires ocaml < 4.12.0
      ...
- javalib -> javalib.2.2.2
    User requested = 2.2.2
- ocaml -> ocaml.4.14.3
    User requested <= 5.1.1
    javalib 2.2.2 requires < 5.0
- ocaml-base-compiler -> (problem)
    User requested >= 4.04.1
    Rejected candidates:
      ocaml-base-compiler.5.2.0~rc1: Requires ocaml = 5.2.0
      ocaml-base-compiler.5.2.0~beta2: Requires ocaml = 5.2.0
      ocaml-base-compiler.5.2.0~beta1: Requires ocaml = 5.2.0
      ocaml-base-compiler.5.2.0~alpha1: Requires ocaml = 5.2.0
      ocaml-base-compiler.5.1.1: Requires ocaml = 5.1.1
      ...