Package ibx

Failed to find a solution:

no platform:
2024-01-29 14:59.25 [INFO] Solving for ocaml-base-compiler, ocaml,
                           ibx using opam_repository_commit 251c5edf2ecdd2541c324dacb931c3606ee71eeb

2024-01-29 14:59.31 [INFO] base: eliminated all possibilities in 3.36 s

2024-01-29 14:59.31 [INFO] = base =

2024-01-29 14:59.31 [INFO] Can't find all required versions.
Selected: base-bigarray.base base-domains.base base-nnp.base
          base-threads.base base-unix.base camlp4.4.02.0-1modular-implicits
          conf-libpcre.1 conf-pkg-config.3 conf-which.1 csexp.1.5.2
          dune.3.13.0 dune-configurator.3.13.0 ocaml-config.3
          ocaml-options-vanilla.1 ocamlbuild.0.14.3 ocamlfind.1.9.6
          pcre.7.5.0 ibx&ocaml&ocaml-base-compiler ocaml-base-compiler
          ocaml-base-compiler ocaml base-domains ocaml ocaml-base-compiler
- async -> async.109.17.00
    ibx 0.5.4 requires < 109.35.00
- async_core -> async_core.109.15.00
    async 109.17.00 requires = 109.15.00
- async_extra -> async_extra.109.17.00
    async 109.17.00 requires = 109.17.00
- async_unix -> async_unix.109.18.00
    async 109.17.00 requires >= 109.17.00 & <= 109.18.00
- core -> (problem)
    async_core 109.15.00 requires >= 109.15.00 & <= 109.18.00
    Rejected candidates:
      core.v0.16.2: Incompatible with restriction: >= 109.15.00 & <= 109.18.00
      core.v0.16.1: Incompatible with restriction: >= 109.15.00 & <= 109.18.00
      core.v0.16.0: Incompatible with restriction: >= 109.15.00 & <= 109.18.00
      core.v0.15.1: Incompatible with restriction: >= 109.15.00 & <= 109.18.00
      core.v0.15.0: Incompatible with restriction: >= 109.15.00 & <= 109.18.00
      ...
- core_extended -> core_extended.109.17.00
    ibx 0.5.4 requires < 109.24.00
- custom_printf -> (problem)
    core_extended 109.17.00 requires = 109.15.00
    Rejected candidates:
      custom_printf.113.00.00: Incompatible with restriction: = 109.15.00
      custom_printf.112.24.00: Incompatible with restriction: = 109.15.00
      custom_printf.112.17.00: Incompatible with restriction: = 109.15.00
      custom_printf.112.06.00: Incompatible with restriction: = 109.15.00
      custom_printf.112.01.00: Incompatible with restriction: = 109.15.00
      ...
- fieldslib -> (problem)
    ibx 0.5.4 requires < 113.01.00
    Rejected candidates:
      fieldslib.v0.16.0: Incompatible with restriction: < 113.01.00
      fieldslib.v0.15.0: Incompatible with restriction: < 113.01.00
      fieldslib.v0.14.0: Incompatible with restriction: < 113.01.00
      fieldslib.v0.13.0: Incompatible with restriction: < 113.01.00
      fieldslib.v0.12.0: Incompatible with restriction: < 113.01.00
      ...
- herelib -> (problem)
    async_unix 109.18.00 requires = 109.15.00
    Rejected candidates:
      herelib.112.35.00: Incompatible with restriction: = 109.15.00
      herelib.109.35.02: Incompatible with restriction: = 109.15.00
      herelib.109.35.00: Incompatible with restriction: = 109.15.00
      herelib.109.15.00: Requires ocaml < 4.06.0
      herelib.109.14.00: Incompatible with restriction: = 109.15.00
      ...
- ibx -> ibx.0.5.4
    User requested = 0.5.4
- ocaml -> ocaml.5.1.0
    User requested <= 5.1.0
- ocaml-base-compiler -> ocaml-base-compiler.5.1.0
    User requested >= 4.04.1
    ocaml-base-compiler|ocaml-variants|ocaml-system|dkml-base-compiler ocaml-base-compiler requires >= 5.1.0~ & < 5.1.1~
- ocaml-variants -> (problem)
    Rejected candidates:
      ocaml-variants.5.3.0+trunk: In same conflict class (ocaml-core-compiler) as ocaml-base-compiler
      ocaml-variants.5.2.0+trunk: In same conflict class (ocaml-core-compiler) as ocaml-base-compiler
      ocaml-variants.5.1.2+trunk: In same conflict class (ocaml-core-compiler) as ocaml-base-compiler
      ocaml-variants.5.1.1+tsan: In same conflict class (ocaml-core-compiler) as ocaml-base-compiler
      ocaml-variants.5.1.1+options: In same conflict class (ocaml-core-compiler) as ocaml-base-compiler
      ...
- sexplib -> (problem)
    ibx 0.5.4 requires < 113.01.00
    Rejected candidates:
      sexplib.v0.16.0: Incompatible with restriction: < 113.01.00
      sexplib.v0.15.1: Incompatible with restriction: < 113.01.00
      sexplib.v0.15.0: Incompatible with restriction: < 113.01.00
      sexplib.v0.14.0: Incompatible with restriction: < 113.01.00
      sexplib.v0.13.0: Incompatible with restriction: < 113.01.00
      ...