Package flowtype

Failed to find a solution:

no platform:
2024-01-29 14:48.22 [INFO] Solving for ocaml-base-compiler, ocaml,
                           flowtype using opam_repository_commit 251c5edf2ecdd2541c324dacb931c3606ee71eeb

2024-01-29 14:48.27 [INFO] base: eliminated all possibilities in 2.54 s

2024-01-29 14:48.27 [INFO] = base =

2024-01-29 14:48.27 [INFO] Can't find all required versions.
Selected: base-bytes.base base-threads.base base-unix.base dune.3.13.0
          gen.1.1 ocaml-config.3 ocaml-secondary-compiler.4.08.1-1
          ocamlbuild.0.14.3 ocamlfind.1.9.6 ocamlfind-secondary.1.9.6
          ppx_derivers.1.2.1 ppx_tools_versioned.5.4.0 result.1.5 sedlex.2.2
          seq.0.3.1 uchar.0.0.2 flowtype&ocaml&ocaml-base-compiler
          ocaml-base-compiler ocaml-base-compiler ocaml&ocamlfind-secondary
- flowtype -> flowtype.0.46.0
    User requested = 0.46.0
- ocaml -> ocaml.4.03.1
    User requested <= 5.1.0
    flowtype 0.46.0 requires >= 4.03.0 & < 4.04.0
- ocaml-base-compiler -> (problem)
    User requested >= 4.04.1
    Rejected candidates:
      ocaml-base-compiler.5.1.1: Requires ocaml = 5.1.1
      ocaml-base-compiler.5.1.1~rc1: Requires ocaml = 5.1.1
      ocaml-base-compiler.5.1.0: Requires ocaml = 5.1.0
      ocaml-base-compiler.5.1.0~rc3: Requires ocaml = 5.1.0
      ocaml-base-compiler.5.1.0~rc2: Requires ocaml = 5.1.0
      ...
- ocaml-migrate-parsetree -> ocaml-migrate-parsetree.1.8.0
    ppx_tools_versioned 5.4.0 requires >= 1.7.0 & < 2.0.0