Package dot-merlin-reader

Failed to find a solution:

no platform:
2024-06-24 13:24.25 [INFO] Solving for ocaml-base-compiler, ocaml,
                           dot-merlin-reader using opam_repository_commit 795f80f1b5a00cb2eea32a4d4e5d8377fa125d62

2024-06-24 13:25.50 [INFO] base: eliminated all possibilities in 1.31 s

2024-06-24 13:25.50 [INFO] = base =

2024-06-24 13:25.50 [INFO] Can't find all required versions.
Selected: base-bigarray.base base-domains.base base-nnp.base
          base-threads.base base-unix.base dune.3.16.0 host-arch-x86_64.1
          ocaml-config.3 ocaml-options-vanilla.1 ocamlfind.1.9.6
          dot-merlin-reader&ocaml&ocaml-base-compiler ocaml-base-compiler
          ocaml-base-compiler system-mingw ocaml base-domains ocaml
          ocaml-base-compiler
- dot-merlin-reader -> dot-merlin-reader.5.1
    User requested = 5.1
- merlin-lib -> (problem)
    dot-merlin-reader 5.1 requires >= 5.1
    Rejected candidates:
      merlin-lib.5.1-502: Requires ocaml >= 5.2 & < 5.3
      merlin-lib.5.0-502: Incompatible with restriction: >= 5.1
      merlin-lib.4.16-501: Incompatible with restriction: >= 5.1
      merlin-lib.4.16-414: Incompatible with restriction: >= 5.1
      merlin-lib.4.15-501: Incompatible with restriction: >= 5.1
      ...
- ocaml -> ocaml.5.1.1
    User requested <= 5.1.1
- ocaml-base-compiler -> ocaml-base-compiler.5.1.1
    User requested >= 4.04.1
    ocaml-base-compiler|ocaml-variants|ocaml-system|dkml-base-compiler ocaml-base-compiler requires >= 5.1.1~ & < 5.1.2~
- system-mingw -> (problem)
    No usable implementations:
      system-mingw.1: Availability condition not satisfied