Package dot-merlin-reader

Failed to find a solution:

no platform:
2024-05-22 09:40.03 [INFO] Solving for ocaml-base-compiler, ocaml,
                           dot-merlin-reader using opam_repository_commit 51268be01852dbdbed8a3ef6599fbe3dfc1c18f7

2024-05-22 09:41.11 [INFO] base: eliminated all possibilities in 1.04 s

2024-05-22 09:41.11 [INFO] = base =

2024-05-22 09:41.11 [INFO] Can't find all required versions.
Selected: base-bigarray.base base-domains.base base-nnp.base
          base-threads.base base-unix.base csexp.1.5.2 dune.3.15.2
          merlin-lib.5.0-502 ocaml-options-vanilla.1 ocamlfind.1.9.6
          dot-merlin-reader&ocaml&ocaml-base-compiler ocaml base-domains
          ocaml ocaml-base-compiler
- dot-merlin-reader -> dot-merlin-reader.5.0-502
    User requested = 5.0-502
- ocaml -> (problem)
    User requested <= 5.1.1
    csexp 1.5.2 requires >= 4.03.0
    dot-merlin-reader 5.0-502 requires >= 5.2
    Rejected candidates:
      ocaml.5.1.1: Incompatible with restriction: >= 5.2
      ocaml.5.1.0: Incompatible with restriction: >= 5.2
      ocaml.5.0.1: Incompatible with restriction: >= 5.2
      ocaml.5.0.0: Incompatible with restriction: >= 5.2
      ocaml.4.14.3: Incompatible with restriction: >= 5.2
      ...
- ocaml-base-compiler -> ocaml-base-compiler.5.2.0
    User requested >= 4.04.1