Package doc-ock-xml

Failed to find a solution:

no platform:
2024-01-29 14:57.35 [INFO] Solving for ocaml-base-compiler, ocaml,
                           doc-ock-xml using opam_repository_commit 251c5edf2ecdd2541c324dacb931c3606ee71eeb

2024-01-29 14:57.41 [INFO] base: eliminated all possibilities in 2.46 s

2024-01-29 14:57.41 [INFO] = base =

2024-01-29 14:57.41 [INFO] Can't find all required versions.
Selected: base-bigarray.base base-domains.base base-nnp.base
          base-threads.base base-unix.base dune.3.13.0 menhir.20231231
          menhirCST.20231231 menhirLib.20231231 menhirSdk.20231231
          ocaml-config.3 ocaml-options-vanilla.1 ocamlbuild.0.14.3
          ocamlfind.1.9.6 topkg.1.0.7 xmlm.1.4.0
          doc-ock-xml&ocaml&ocaml-base-compiler ocaml-base-compiler
          ocaml-base-compiler ocaml base-domains ocaml ocaml-base-compiler
- doc-ock -> (problem)
    Rejected candidates:
      doc-ock.1.2.1: Requires ocaml >= 4.03.0 & < 4.08.0
      doc-ock.1.2.0: Requires ocaml >= 4.03.0 & < 4.08.0
      doc-ock.1.1.1: Requires ocaml >= 4.03.0 & < 4.06
      doc-ock.1.1.0: Requires ocaml >= 4.03.0 & < 4.06
      doc-ock.1.0.0: Requires ocaml >= 4.03.0 & < 4.04
- doc-ock-xml -> doc-ock-xml.1.0.0
    User requested = 1.0.0
- ocaml -> ocaml.5.1.0
    User requested <= 5.1.0
- ocaml-base-compiler -> ocaml-base-compiler.5.1.0
    User requested >= 4.04.1
    ocaml-base-compiler|ocaml-variants|ocaml-system|dkml-base-compiler ocaml-base-compiler requires >= 5.1.0~ & < 5.1.1~