Package core_profiler

Failed to find a solution:

no platform:
2024-01-29 15:04.28 [INFO] Solving for ocaml-base-compiler, ocaml,
                           core_profiler using opam_repository_commit 251c5edf2ecdd2541c324dacb931c3606ee71eeb

2024-01-29 15:04.34 [INFO] base: eliminated all possibilities in 2.61 s

2024-01-29 15:04.34 [INFO] = base =

2024-01-29 15:04.34 [INFO] Can't find all required versions.
Selected: base-ocamlbuild.base camlp4.4.02.0-1modular-implicits conf-which.1
          enumerate.111.08.00 ocaml-config.3 ocamlbuild.0 ocamlfind.1.9.6
          ounit.2.2.7 pa_test.112.24.00
          core_profiler&ocaml&ocaml-base-compiler ocaml-base-compiler
          ocaml-base-compiler
- bin_prot -> bin_prot.112.24.00
    core 112.24.01 requires >= 112.24.00 & < 112.25.00
- comparelib -> comparelib.109.60.00
    core 112.24.01 requires >= 109.60.00 & < 109.61.00
- core -> core.112.24.01
    core_extended 112.24.00 requires >= 112.24.00 & < 112.25.00
- core_extended -> core_extended.112.24.00
    core_profiler 112.19.01 requires >= 112.17.00 & < 112.25.00
- core_kernel -> core_kernel.112.24.00
    core 112.24.01 requires >= 112.24.00 & < 112.25.00
- core_profiler -> core_profiler.112.19.01
    User requested = 112.19.01
- custom_printf -> custom_printf.112.24.00
    core 112.24.01 requires >= 112.24.00 & < 112.25.00
- fieldslib -> fieldslib.109.20.03
    core 112.24.01 requires >= 109.20.00 & < 109.21.00
- herelib -> herelib.109.35.02
    core 112.24.01 requires >= 109.35.00 & < 109.36.00
- ocaml -> ocaml.4.02.4
    User requested <= 5.1.0
    base-ocamlbuild base requires >= 3.10 & < 4.03
- ocaml-base-compiler -> (problem)
    User requested >= 4.04.1
    Rejected candidates:
      ocaml-base-compiler.5.1.1: Requires ocaml = 5.1.1
      ocaml-base-compiler.5.1.1~rc1: Requires ocaml = 5.1.1
      ocaml-base-compiler.5.1.0: Requires ocaml = 5.1.0
      ocaml-base-compiler.5.1.0~rc3: Requires ocaml = 5.1.0
      ocaml-base-compiler.5.1.0~rc2: Requires ocaml = 5.1.0
      ...
- ocaml-variants -> (problem)
    camlp4 4.02.0-1modular-implicits requires = 4.02.0+modular-implicits | = 4.02.1+modular-implicits-ber
    Rejected candidates:
      ocaml-variants.5.3.0+trunk: Incompatible with restriction: = 4.02.0+modular-implicits | = 4.02.1+modular-implicits-ber
      ocaml-variants.5.2.0+trunk: Incompatible with restriction: = 4.02.0+modular-implicits | = 4.02.1+modular-implicits-ber
      ocaml-variants.5.1.2+trunk: Incompatible with restriction: = 4.02.0+modular-implicits | = 4.02.1+modular-implicits-ber
      ocaml-variants.5.1.1+tsan: Incompatible with restriction: = 4.02.0+modular-implicits | = 4.02.1+modular-implicits-ber
      ocaml-variants.5.1.1+options: Incompatible with restriction: = 4.02.0+modular-implicits | = 4.02.1+modular-implicits-ber
      ...
- ounit2 -> (problem)
    ounit 2.2.7 requires = 2.2.7
    Rejected candidates:
      ounit2.2.2.7: Requires ocaml >= 4.04.0
      ounit2.2.2.6: Incompatible with restriction: = 2.2.7
      ounit2.2.2.5: Incompatible with restriction: = 2.2.7
      ounit2.2.2.4: Incompatible with restriction: = 2.2.7
      ounit2.2.2.3: Incompatible with restriction: = 2.2.7
      ...
- pa_bench -> pa_bench.112.06.00
    core 112.24.01 requires >= 112.06.00 & < 112.07.00
- pa_ounit -> pa_ounit.112.24.00
    core 112.24.01 requires >= 112.24.00 & < 112.25.00
- pipebang -> pipebang.110.01.00
    core 112.24.01 requires >= 110.01.00 & < 110.02.00
- re2 -> re2.112.06.00
    core_extended 112.24.00 requires >= 112.06.00 & < 112.07.00
- sexplib -> sexplib.112.24.01
    core 112.24.01 requires >= 112.24.00 & < 112.25.00
- textutils -> textutils.112.17.00
    core_extended 112.24.00 requires >= 112.17.00 & < 112.18.00
- type_conv -> type_conv.112.01.02
    bin_prot 112.24.00 requires >= 112.01.00 & < 112.02.00
- typerep -> typerep.112.24.00
    core_kernel 112.24.00 requires >= 112.24.00 & < 112.25.00
- variantslib -> variantslib.109.15.03
    core 112.24.01 requires >= 109.15.00 & < 109.16.00