Package camlp4

Failed to find a solution:

no platform:
2024-01-29 15:14.47 [INFO] Solving for ocaml-base-compiler, ocaml,
                           camlp4 using opam_repository_commit 251c5edf2ecdd2541c324dacb931c3606ee71eeb

2024-01-29 15:14.52 [INFO] base: eliminated all possibilities in 2.15 s

2024-01-29 15:14.52 [INFO] = base =

2024-01-29 15:14.52 [INFO] Can't find all required versions.
Selected: ocaml-config.3 camlp4&ocaml&ocaml-base-compiler ocaml-base-compiler
          ocaml-base-compiler
- camlp4 -> camlp4.4.05+system
    User requested = 4.05+system
- ocaml -> ocaml.4.05.1
    User requested <= 5.1.0
    camlp4 4.05+system requires >= 4.05 & < 4.06
- ocaml-base-compiler -> (problem)
    User requested >= 4.04.1
    Rejected candidates:
      ocaml-base-compiler.5.1.1: Requires ocaml = 5.1.1
      ocaml-base-compiler.5.1.1~rc1: Requires ocaml = 5.1.1
      ocaml-base-compiler.5.1.0: Requires ocaml = 5.1.0
      ocaml-base-compiler.5.1.0~rc3: Requires ocaml = 5.1.0
      ocaml-base-compiler.5.1.0~rc2: Requires ocaml = 5.1.0
      ...
- ocaml-system -> (problem)
    No usable implementations:
      ocaml-system.5.1.1: Availability condition not satisfied
      ocaml-system.5.1.0: Availability condition not satisfied
      ocaml-system.5.0.0: Availability condition not satisfied
      ocaml-system.4.14.1: Availability condition not satisfied
      ocaml-system.4.14.0: Availability condition not satisfied
      ...