Package batsh

Failed to find a solution:

no platform:
2024-01-29 14:44.49 [INFO] Solving for ocaml-base-compiler, ocaml,
                           batsh using opam_repository_commit 251c5edf2ecdd2541c324dacb931c3606ee71eeb

2024-01-29 14:44.55 [INFO] base: eliminated all possibilities in 2.68 s

2024-01-29 14:44.55 [INFO] = base =

2024-01-29 14:44.55 [INFO] Can't find all required versions.
Selected: base-bigarray.base base-domains.base base-nnp.base
          base-threads.base base-unix.base camlp4.4.02.0-1modular-implicits
          cmdliner.1.2.0 conf-which.1 dlist.0.1.0 ocaml-config.3
          ocaml-options-vanilla.1 ocamlbuild.0.14.3 ocamlfind.1.9.6
          batsh&ocaml&ocaml-base-compiler ocaml-base-compiler
          ocaml-base-compiler ocaml base-domains ocaml-base-compiler
- batsh -> batsh.0.0.6
    User requested = 0.0.6
- core -> (problem)
    batsh 0.0.6 requires >= 109.47.00 & <= 113.00.00
    Rejected candidates:
      core.v0.16.2: Incompatible with restriction: >= 109.47.00 & <= 113.00.00
      core.v0.16.1: Incompatible with restriction: >= 109.47.00 & <= 113.00.00
      core.v0.16.0: Incompatible with restriction: >= 109.47.00 & <= 113.00.00
      core.v0.15.1: Incompatible with restriction: >= 109.47.00 & <= 113.00.00
      core.v0.15.0: Incompatible with restriction: >= 109.47.00 & <= 113.00.00
      ...
- core_kernel -> (problem)
    batsh 0.0.6 requires >= 109.47.00 & <= 113.00.00
    Rejected candidates:
      core_kernel.v0.16.0: Incompatible with restriction: >= 109.47.00 & <= 113.00.00
      core_kernel.v0.15.0: Incompatible with restriction: >= 109.47.00 & <= 113.00.00
      core_kernel.v0.14.2: Incompatible with restriction: >= 109.47.00 & <= 113.00.00
      core_kernel.v0.14.1: Incompatible with restriction: >= 109.47.00 & <= 113.00.00
      core_kernel.v0.14.0: Incompatible with restriction: >= 109.47.00 & <= 113.00.00
      ...
- ocaml -> ocaml.5.1.0
    User requested <= 5.1.0
- ocaml-base-compiler -> ocaml-base-compiler.5.1.0
    User requested >= 4.04.1
    ocaml-base-compiler|ocaml-variants|ocaml-system|dkml-base-compiler ocaml-base-compiler requires >= 5.1.0~ & < 5.1.1~
- ocaml-variants -> (problem)
    Rejected candidates:
      ocaml-variants.5.3.0+trunk: In same conflict class (ocaml-core-compiler) as ocaml-base-compiler
      ocaml-variants.5.2.0+trunk: In same conflict class (ocaml-core-compiler) as ocaml-base-compiler
      ocaml-variants.5.1.2+trunk: In same conflict class (ocaml-core-compiler) as ocaml-base-compiler
      ocaml-variants.5.1.1+tsan: In same conflict class (ocaml-core-compiler) as ocaml-base-compiler
      ocaml-variants.5.1.1+options: In same conflict class (ocaml-core-compiler) as ocaml-base-compiler
      ...
- ocp-build -> (problem)
    batsh 0.0.6 requires = 1.99.8-beta
    Rejected candidates:
      ocp-build.1.99.21: Incompatible with restriction: = 1.99.8-beta
      ocp-build.1.99.20-beta: Incompatible with restriction: = 1.99.8-beta
      ocp-build.1.99.19-beta: Incompatible with restriction: = 1.99.8-beta
      ocp-build.1.99.18-beta: Incompatible with restriction: = 1.99.8-beta
      ocp-build.1.99.17-beta: Incompatible with restriction: = 1.99.8-beta
      ...